Forte hang in Rack Editor (latest stable and beta)

Post here if you are having a problem with or a question about forte that is not about a plugin or audio/MIDI hardware.

Moderator: MikeG

tklute
Posts: 3
Joined: Sun Sep 27, 2015 4:34 pm

Forte hang in Rack Editor (latest stable and beta)

Postby tklute » Sun Sep 27, 2015 4:54 pm

Hi Forte support team,
I just bought Forte because I've read it is rock solid and stable... mh...
Playing around with forte it hung several times while trying to add scenes to songs in the rack editor.
It turned out that I forgot to select a song, but the insert button was enabled and caused the problem.
I tried with the latest stable and beta version, both show the same problems.

Is anybody able to reproduce this:
1) Start with a new, empty rack (File->New->Rack)
2) add one instrument
3) click on "new scene" to create one scene
4) click on "rack editor"
5) in the rack editor, select the scene from the scene pool (just click on that scene)
6) "insert" button in the "song pool" area will be enabled now (has a green bar), although we have no song
7) click on that "insert" button.
After that I'm unable to close the rack editor, it does not react to any command, I have to kill the forte task using the task manager.

The same happens when there are songs but none of them is selected or the selection is removed by clicking somewhere else in the "song pool" table.
The button should only be enabled if a scene _and_ a song is selected...

I'm using Windows 10, x64 forte, version 4.1 build 5.21 (latest beta) and latest stable version before (don't know the exact version number now).

Thanks and best regards,
Thomas

tklute
Posts: 3
Joined: Sun Sep 27, 2015 4:34 pm

Re: Forte hang in Rack Editor (latest stable and beta)

Postby tklute » Sun Sep 27, 2015 5:26 pm

...and some more bugs found in my version/installation:
1)
- Selecting a song but no scene also enables the "insert" button (but does not cause a hang)

2)
- The "up" button to reorder scenes within a song works fine. But the "down" button does not.
- Trying to move the first scene down does not work at all
- Trying to move any other scene down moves that scene to the top

Burtan
Posts: 463
Joined: Sun May 29, 2011 1:16 pm

Re: Forte hang in Rack Editor (latest stable and beta)

Postby Burtan » Mon Sep 28, 2015 3:10 am

I'm a long year Forte user and I can confirm that editing your rack can sometimes lead to crashes, but when you just play your rack instead of editing it's really stable.

evilantal
Posts: 389
Joined: Sun Mar 23, 2008 6:41 am
Location: Arnhem, the Netherlands
Contact:

Re: Forte hang in Rack Editor (latest stable and beta)

Postby evilantal » Mon Sep 28, 2015 5:05 am

Yes, I agree with Burtan.
Although the intermittent crashes when working with rack editor are certainly annoying, I have never had forte crash on me while just playing the rack in a live situation. And I've been using forte live since 2006.
Lenovo Z500, quad core i7 3632QM, 16GB 1600MHz DDR3, RME BabyFace, Samsung EVO SSD x2, forte 4, Kawai ES100, Kurzweil PC2, VB3, Alchemy, Kontakt 5, Omnisphere 2, Diva, ZebraHZ, Bazille, Pianoteq 5 Standard, Falcon, various effects

tklute
Posts: 3
Joined: Sun Sep 27, 2015 4:34 pm

Re: Forte hang in Rack Editor (latest stable and beta)

Postby tklute » Mon Sep 28, 2015 12:41 pm

Hi,
thanks for the reply.
Glad to hear that.
Nevertheless - these bugs should be easy to fix. It's just user interface stuff.
Does the support team read the forum or should I report that directly using the support form?

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Forte hang in Rack Editor (latest stable and beta)

Postby MikeG » Mon Sep 28, 2015 7:41 pm

Thank you for the report - working on fixes.
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.


Return to “Forte and EHCo”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests