Hypersonic 2 / 64bits (one more time !)

Post here if you encounter problems using a plugin in forte

Moderator: MikeG


Hypersonic 2 / 64bits (one more time !)

Postby vdave » Thu Jun 06, 2013 9:23 am

Hi, I've read many topics about Hypersonic 2 in 64 bits systems, and I know it's not easy to set-up.
I saw that many persons decided to not use it anymore for that reason.
But I've been able to install it on win8 64, and it works very well in forte 3 32bits.
When I open my rack with 5 instances of Hypersonic (rack previously created with forte 2 in winxp), it loads and plays without any problem. :D


rack can't be saved. :cry:

It says :
[i]Unrecoverable error saving rack /....../.rcf. Saving mixer (saving instrument "Hypersonic")
Forte cannot continue and will crash.[/i]

So, as Hypersonic loads and plays very well, maybe the error saving rack could be avoided ?

(For now, when I've to save a change in my rack, I start forte in save mode, desactive hypersonic plugin, load the rack, make changes and save. Then, next time when I load the rack normally, all works fine. Of course I can't save changes in hypersonic, because it's not loaded when I save 8) )

It took me several days to be able to load and play hypersonic, and now it's nearly ok, I just need the last little "boost" to have it perfectly running :mrgreen:



Posts: 48
Joined: Wed Aug 16, 2006 1:53 pm
Location: France

Re: Hypersonic 2 / 64bits (one more time !)

Postby Lucien » Mon Jun 10, 2013 2:41 am

Hi vdave.
I always use Hypersonic 2 with Forte 3.2 64 bits and Windows 7.
It run with jBridge.
I use “Do not set per-Scene plugin configuration” and I recall the performance with a PRG Change (channel 16)
I have a few crashes, but I can use it.
I have so many racks mounted with Hypersonic 2, I cannot live without !!
I tried Halion Sonic, but access is more difficult and we cannot recall the performance with a PRG change, despite being marked in the manual ....
But I'm like you, I just need the last little "boost" to have it perfectly running.


Re: Hypersonic 2 / 64bits (one more time !)

Postby vdave » Wed Jun 12, 2013 11:35 am

Hi Lucien !
So I'm not the last one to use Hypersonic :-)
(I have not been able to use hypersonic properly with jbridge.)

Finally I solved my "bug" !
As my rack file is the same from a long time (7years!) and I update it all the time, though forte's versions, plugins evolutions, and so on, it came on forte 3 with something I'd call a bug : To solve it I had to change the scene settings of hypersonic from "do-not-set-per-scene..." to "auto...". So it was possible to save the rack. And then I set again the scene setting to "do-not..." , save again, and now it rocks :D

Maybe that will help someone...


Posts: 26
Joined: Tue Aug 25, 2009 4:39 am

Re: Hypersonic 2 / 64bits (one more time !)

Postby glenny_g » Wed Dec 11, 2013 10:34 pm

AFter hours of messing about I seem to have Hypersonic 2 working in Forte 3 Performer 64 bit. I have tested this by loading Hypersonic 2, loading various programs, taking snapshots, switching between scenes, saving the rack file, loading the rack file and confirming that all the scenes work as per normal.
I'll post again if I come across any crashes etc. but so far it works like a dream.

While you are testing all this, it might be best to point your Forte plugin manager to a folder with ONLY the bridged Hypersonic file in it and do a full rescan so ONLY the 64 bit bridged Hypersonic is in your list of available plugins. Once you are sure it works, add your other vst folders into the plugin manager and scan again to get all your plugins back. If you use the built-in jBridge in Forte, it will probably mess up your tweaked Hypersonic.jBridge file, so maybe use the jBridger tool instead and confirm individually, skipping the Hypersonic file. Always use the "in a directory I'll specify" option and then later point Forte to that, not your original vst folder. If you previously used the built-in j.Bridge in Forte, it might be a good idea to delete all the .jBridge files in your vst folders EXCEPT the Hypersonic one which you got working properly.

Here's what I did:

I bridged Hypersonic.dll with the jBridger Tool instead of using the built-in jBridge option in Forte. Using the tool I selected the "using a 64 bit host", "confirm files individually", "use a directory I'll specify". I pointed the tool at Hypersonic.dll in my x86 vst folder and did the bridge. I have a folder in my x64 Program Files that I keep my 64-bit bridged files in.

In the x86 vst folder where the original Hypersonic.dll lives, there is now also a Hypersonic.jBridge file. I opened that and made the following settings. You could copy all this and make this the .jBridge file if you want. Copy between the ----------------- lines. Or just open the existing one in Notepad, make the following settings and save.
//EXPERTS ONLY - unless stated otherwise: 0 - disabled ; 1 - enabled ; all other values will be

-Reload the plugin for changes to take effect!!







//( not listed in the settings menu )By default, all the plugins running in the same auxhost will

be in group 0, if you wish to group specific plugins in different auxhost's, change this value

somewhere between 1 and 64

//( not listed in the settings menu )Set this option to 1 if your bridged plugin hangs when loading

a project.

//auxhost priority(experts only!) - 0 is default ; 1( lowest ) to 7 (highest) ; all other values

will be ignored

//set to 0 to disable "forcing auxhost termination(...)" message

//uses v1.2 integrated mode implementation if 1 ( enabled by default for backward compatibility

purposes ).May need to be set to 0 for automation to work in some hosts (i.e., Ableton Live)

//Plugin's GUI will be opened on a separated window if set to 1

//Auto-closes the plugin's GUI when the settings window is closed (Separated GUI mode only)

//Audio buffers will be processed asynchronously, can improve performance with some plugin/host


//Set to 1 if you're experiencing opcode 19 error messages

//Set to 1 if you're experiencing long delays and an opcode error message when closing/re-opening

the plugin's GUI

//Set to 1 if you're experiencing crashes when unloading a bridged plugin

//( separated GUI mode ) keeps the plugin's GUI window always visible if 1

//( not listed in the settings menu )Experimental option, disables processing of deprecated opcodes

if 0

//Loads the plugin in GUIless mode ( for plugins that have no GUI, when used in a VST host that

supports those ).
//You will not be able to access jBridge's options if you change this to 1 without editing the

settings file and changing it back to 0

And your window when you open Hypersonic will only have the "Audiomaster get time hack" and "use thread safety measures" boxes ticked. The Hypersonic GUI is in a separate window that will either be minimised to your tray or opened by clicking the Hey, where's my GUI? button.

Hope it works for you all as well as it does for me. Only took many hours of trying various stuff.
Last edited by glenny_g on Thu Dec 12, 2013 8:35 pm, edited 1 time in total.

Posts: 26
Joined: Tue Aug 25, 2009 4:39 am

Re: Hypersonic 2 / 64bits (one more time !)

Postby glenny_g » Wed Dec 11, 2013 10:37 pm

BTW, I'm using jBridge 1.5 and Performer 3.0.47

Posts: 26
Joined: Tue Aug 25, 2009 4:39 am

Re: Hypersonic 2 / 64bits (one more time !)

Postby glenny_g » Thu Dec 12, 2013 8:35 pm

Have found that the GUI window might need to be open for Hypersonic to get udated on scene change.

Posts: 26
Joined: Tue Aug 25, 2009 4:39 am

Re: Hypersonic 2 / 64bits (one more time !)

Postby glenny_g » Sun Jan 19, 2014 11:18 pm

Yeah....it works MOST of the time but not reliably enough to use on gigs. Such a shame Steinberg let it go. Halion Sonic is nowhere near as good. Sigh. I'll miss you, Hypersonic.
PS: It would be GREAT if whatever quirk in Hypersonic is causing crashes in Forte 64bit could be allowed for in a Forte update so we can use it again!

Return to “Plugin Issues”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests