Questions related to plugin initialization

Post here if you are having a problem with or a question about forte that is not about a plugin or audio/MIDI hardware.

Moderator: MikeG

Mr Beverage
Posts: 57
Joined: Tue Mar 17, 2015 6:39 am

Questions related to plugin initialization

Postby Mr Beverage » Sun Jul 12, 2015 9:05 am

My observation is that when an instrument bus is un-muted (for the first time ONLY after a rack file is opened) or Forte loads a rack to it's first scene, Forte "talks" to that plugin and somehow adjusts/re-adjusts parameter settings.
That "message" sent by Forte and recieved by the plugin instrument is causing the plugin settings to change to a "garbage" setting.
(all organ stops pulled out and any and all knobs set all the way "off", or "to the left")
ie. Kontakt Vintage Organ MODE setting turns to LOWER when it was saved with the instrument to be UPPER or MIDI SPLIT.
If I open a rack file with Kontakt Organ instrument bus muted... then open the Console... and then un-mute the bus, I can actually WATCH the organ change from it's saved values to the "garbage" values.
So...

Question #1: Is there a way to intercept this data/code being sent to the plugin by Forte?
Question #2: If there are no MIDI program changes set under Scene Commands, then how is the plugin initialized?

I hope that I have explained this problem clear enough for the programmers to understand.
Thanks much,
Mr B.

Return to “Forte and EHCo”

Who is online

Users browsing this forum: No registered users and 1 guest