Forte 4 (random?) crash when saving rack/updating scene

Post here if you are having a problem with or a question about forte that is not about a plugin or audio/MIDI hardware.

Moderator: MikeG

DarkKman
Posts: 168
Joined: Wed Jan 11, 2012 10:07 am

Forte 4 (random?) crash when saving rack/updating scene

Postby DarkKman » Sat Dec 06, 2014 6:09 pm

Hi,

As MIke may have seen (lots of logs sent) Forte 4 is crashing on me when I'm trying to save a rack or, on occasion, when updating a scene - the same changes to the same rack in Forte 3 are fine. It happens more often than not but occasionally I HAVE been able to update a scene/save rack - 1 time in 20 perhaps.

There is a message saying "Forte is going to crash and will close" and upon testing the same rack in Forte 3 I *think* the issue may be to do with the old Kontakt 5 data size error:

"Error: 'Kontakt 5' generated an exception when asked for the size of its save data. This rack file may be corrupted if you save. Press OK to save or Cancel to stop."

I get this error on occasion in Forte 3 when updating scene/saving rack and seems to happen in this particular rack in Forte 3 with the same frequency with which Forte 4 just crashes...

Not sure anyone can help but here as reference.

In the meantime I am back to using Forte 3 to edit racks then use them in F4... Frustrated!

img
Posts: 3
Joined: Wed Aug 06, 2014 7:04 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby img » Tue Dec 23, 2014 8:11 am

:roll: +1

mhertzbe
Posts: 42
Joined: Mon Oct 18, 2010 11:45 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby mhertzbe » Tue Dec 23, 2014 7:49 pm

I'm seeing what looks like the same thing (also running Kontakt 5, BTW).

I was able to save the first Forte 3 rack I opened in Forte 4. Then I added a couple of buses and auxes and was able to save that rack. Haven't been able to save the rack that has the new buses ever since.

I uploaded a crash log.

M
Forte 4 hosting NI Guitar Rig, Kontakt, and Aux Bus Set on a Dell Precision M4700 with SSD and 24GB memory. Oxygen 88 keyboard/controller and Steinberg UR44 Midi/Audio I/O

img
Posts: 3
Joined: Wed Aug 06, 2014 7:04 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby img » Sun Feb 01, 2015 6:53 pm

Kontakt 5.4.3.307, same problem :shock:

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby MikeG » Tue Feb 03, 2015 1:32 am

A quick experiment is not reproducing this. Is there a specific rack file you can email to support that I can use to try to repro this?
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

img
Posts: 3
Joined: Wed Aug 06, 2014 7:04 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby img » Wed Feb 04, 2015 7:07 pm


Burtan
Posts: 463
Joined: Sun May 29, 2011 1:16 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Burtan » Thu Feb 05, 2015 1:13 pm

I'm experiencing this crash dialog as well, but my rack is actually not crashing. Thus I'm just ignoring it and try to resave it. It will mostly work after switching to another scene or toggle power off/on.

DarkKman
Posts: 168
Joined: Wed Jan 11, 2012 10:07 am

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby DarkKman » Fri Feb 06, 2015 7:27 pm


Burtan
Posts: 463
Joined: Sun May 29, 2011 1:16 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Burtan » Sat Feb 07, 2015 1:42 am

Yes, the behaviour is the same in F3 and F4 for me.

John Dumke
Posts: 24
Joined: Mon Feb 24, 2014 6:52 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby John Dumke » Mon Mar 16, 2015 1:48 am

I spent all day trying to get Forte 4 to work with the latest version of Kontakt 5 and Chris Hein Horns. I tried just about everything, but Forte crashes with the same error message above.

I went back to one of my Forte 3 racks and Chris Hein Horns works fine within Kontakt 5, so it is likely the latest version of Forte 4 that is the issue. A support email was sent

yamus
Posts: 488
Joined: Fri Sep 15, 2006 8:36 am

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby yamus » Mon Mar 16, 2015 10:00 pm

Hi John,

If I fire up forte 4 (x64), load Kontakt 5, and load patches from Chris Hein horns, it works fine. Maybe you can be more specific about exactly what you're doing to cause a crash and I can try to reproduce it?

-Mike (not THE Mike of Brainspawn... just a user)

Nexus52085
Posts: 5
Joined: Tue Mar 17, 2015 3:57 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Nexus52085 » Tue Mar 17, 2015 4:07 pm

I'm having the same issue, and it's starting to scare me. I'm simply building a rack and it's crashing almost every time I try to save. I'm not even changing scenes. I've set the Scene Commands to "Do not set per-Scene plugin..." It seems to be more stable if I run multiple instances of Kontakt and make sure the Kontakt "libraries" aren't loaded in the same instance as non "library" samples. However, I'm still not sure if this is ultimately the issue.

I've got a show in a little over a month and I really don't have time for this. A fix needs to happen soon.

John Dumke
Posts: 24
Joined: Mon Feb 24, 2014 6:52 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby John Dumke » Wed Mar 18, 2015 3:13 am


John Dumke
Posts: 24
Joined: Mon Feb 24, 2014 6:52 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby John Dumke » Wed Mar 18, 2015 4:43 pm

Testing Forte 4.0.14 (64 bit) with Kontakt 5 (5.4.3.307) with Chris Hein Horns (ver 1.0.0)
System Win 8.1 64 bit

1) Opened Forte 4, created new rack, created scene, added Kontakt 5 added Instrument 1CHH Compact Full (a Multi). Updated scene, Save Rack (CRASH)
2) Reload Forte 4 same test rack with only Kontakt. No instrument is present, Add just an individual instrument CHH C-18 Trumpet Solo, Update scene, save rack (SAVED!)
3) Add CHH C-36 Trombone Bass, Update Scene, Save Rack (SAVED!)
4) Deleted both instruments and tried to add back in 1 CHH Compact Full (multi) , updated scene, saved (CRASH)
5) Reloaded Forte 4 test rack and loaded 4 CHH Compact Trombone (a Multi), updated Scene, save rack (SAVED!)
6) Deleded 4 CHH Compact Trombone and loaded 3 CHH Compact Sax Clari, updated Scene, save rack (SAVED!)

So at this Point it looks like the 1 CHH Compact Full which is crashing the system.

7) Maybe this file is corrupt. I unpacked the original Files and over wrote the instrument in the Library, and loaded 1 CHH Compact Full into Kontakt, update scene, save rack, (CRASH)
8) Maybe there is some instrument within the 1 CHH Compact Full Multi that Forte doesn't like. I load the 1 CHH Compact Full Multi into Kontakt, set each instrument to --EMPTY-- and unclick the red load button. No everything is deactivated. Update Scene, save rack (SAVED!)

Now We are getting somewhere....

9) Load Trumpet Solo back into the first slot within the Multi and click the Red "L" button, update scene, save rack (CRASH)

Tried loading several other instruments into other slots and each time the 1 CHH Compact Multi CRASHES.

Nexus52085
Posts: 5
Joined: Tue Mar 17, 2015 3:57 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Nexus52085 » Wed Mar 18, 2015 8:10 pm

Okay, I've been working with the issue for a few days now. So far, all I have been doing is building my rack, so I have not been programming scene changes or testing the stability with switching between scenes. At any rate, here's what I've noticed.

This is what I have in my rack so far:
Forte 4.0.14 64-bit running
1 module of PLAY (QL RA)
1 module of Pianoteq 5
1 module of Absynth
1 module of FM8
4 modules of Kontakt 5 (Kontakt library, CineSympony Lite, Vintage EP, Albion Skaila Kanga Harp Redux)
1 module of ARIA player (multi)
(All VST's are running in 64-bit)
This is running on a Surface Pro 3, core i5, 256GB, 8GB ram.

EVERY time it crashes, the error report has to do with Kontakt. So, something between Forte and Kontakt just isn't working well. I'll preface this by saying I disabled multicore processing within each instance of kontakt, changed the scene commands to "Do not set per-Scene...", and have tried disabling the audio engine. After all of that, I've come to these conclusions.

1) Forte doesn't seem to like Kontakt if it has too many instruments loaded into one instance ("module" in this case).

2) I've also run into crashes if the patches take up too much ram per instance. For example, I can run 3 instruments of Cinesamples CineSymphony Lite and two other small Kontakt instruments, and that takes up about 0.55 GB. If I try to add anything else, it becomes increasingly difficult to save without crashing. However, if I open up a new instance of Kontakt and put those same instruments that caused the crash in the new instance, I can save just fine.

The immediate takeaway, so far, is to just load more instances of Kontakt and try not to have too many instruments in each instance. This seems to stabilize my rack somewhat. An obvious step if you do this, though, is to disable multicore processing in each instance and allow Forte to handle that.

3) One library in particular that doesn't seem to run well is NI Session Strings Pro. The GUI just loads incorrectly. I'm not sure what this is. It could possibly be a bad install, but it works fine in other DAWs (pro tools and cubase). I've also already reinstalled it once, and I don't want to bother doing that again. lol

Feel free to chime in...

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby MikeG » Wed Mar 18, 2015 8:57 pm

I've seen a number of submitted crash reports concerning Kontakt 5 and saving a rack file with Forte. I'll have a better feel for this issue once I can reproduce it myself. My simple attempts have not reproduced it so it may have to so with the specific instruments loaded.
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

John Dumke
Posts: 24
Joined: Mon Feb 24, 2014 6:52 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby John Dumke » Fri Mar 20, 2015 8:27 pm


MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby MikeG » Fri Mar 27, 2015 12:55 pm

I think I have this fixed in build 4.0.15 - please check it out and thanks much to everyone for helping me reproduce it.
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

John Dumke
Posts: 24
Joined: Mon Feb 24, 2014 6:52 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby John Dumke » Fri Mar 27, 2015 4:10 pm

[quote=11"MikeG"]I think I have this fixed in build 4.0.15 - please check it out and thanks much to everyone for helping me reproduce it.[/quote]

Brilliant! - Seems to have fixed it on my end. Just ran one test, a simple rack with ONLY Kontakt and Chris Hein Horns 1-CHH Multi. This simple rack would crash anytime I would attempt to save the rack. Now all is good.

THANK YOU!
Last edited by John Dumke on Fri Mar 27, 2015 5:00 pm, edited 1 time in total.

DarkKman
Posts: 168
Joined: Wed Jan 11, 2012 10:07 am

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby DarkKman » Fri Mar 27, 2015 4:30 pm

Seconded! The initial issue posted appears resolved! Great work, Mike! Thank you...!

tekhedd
Posts: 17
Joined: Sun Feb 02, 2014 5:11 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby tekhedd » Thu Apr 02, 2015 6:41 pm

I am so relieved to see this thread. I was coming to the forum to see if I could disable save *entirely* for Kontakt, because even with all my patches rolled into one big patch and "Do not set scene configuration" it still crashes on save.

I've been having this problem for about a year now with forte 3 and 4, both 32 and 64 bit versions. (See the various other threads). You could ignore the error with Forte 3, but sometimes this would corrupt random settings in the save. (ran into this on stage it was very freaky!) Glad I'm not the only one having this error (actually a known issue if you reported it to NI, from the way they also shrugged it off--guess now that they're selling hardware they don't care about third parties any more. Is *that* frightening or what?) I will try 4.0.15 for the next few weeks --so far it seems to be actually capable of saving. But then my crashing was very intermittent with the first release of 4.0 so...

So... er... I'm glad because this *is* turning into a "search for alternate solutions" issue. I quite like Forte and to be honest I'd replace Kontakt first, but any change would be very time consuming at this stage.

Burtan
Posts: 463
Joined: Sun May 29, 2011 1:16 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Burtan » Fri Apr 03, 2015 8:55 am

Did some work yesterday and today and this crash did not appear with 4.0.15 yet :-)

tekhedd
Posts: 17
Joined: Sun Feb 02, 2014 5:11 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby tekhedd » Tue Apr 14, 2015 2:43 pm

I am stable with 4.0.15 (x64). I still sometimes see a crash on exit if I have edited the Kontakt parameters, but as this does not cause problems with the save it is far from mission critical. I will try to upload the crash reports; it usually happens when I'm breaking down and definitely not feeling patient. :)

Really like version 4.

Nexus52085
Posts: 5
Joined: Tue Mar 17, 2015 3:57 pm

Re: Forte 4 (random?) crash when saving rack/updating scene

Postby Nexus52085 » Tue Apr 21, 2015 12:42 pm

Mike,

I hadn't posted in a while because I've been busy programming on the far more stable build of 4.0.15! Thank you so much for your hard work and quick turnaround. I am beyond happy that I was able to finish programming in time for the show and with confidence. It still has crashes here and there, but it is FAR more manageable. Thanks again!


Return to “Forte and EHCo”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests