Midi scene change after 127

Post here if you are having a problem with or a question about forte that is not about a plugin or audio/MIDI hardware.

Moderator: MikeG

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Midi scene change after 127

Postby bigalminal » Sat Oct 18, 2014 2:30 am

I've arrived at scene 127 in Forte and need to go past that via midi. How to I set the bank number so that my lyrics program can send the correct bank and program change?

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Sun Oct 19, 2014 11:50 pm

Hello - 17 views but no answer. Can someone help me here? I have looked in the manual and experimented. Cant get consistent results.

evilantal
Posts: 389
Joined: Sun Mar 23, 2008 6:41 am
Location: Arnhem, the Netherlands
Contact:

Re: Midi scene change after 127

Postby evilantal » Mon Oct 20, 2014 1:09 am

I've never gone past 127 scenes myself.
It wouldn't affect me though, because I set up a setlist in advance and just go through it using "next scene".
Lenovo Z500, quad core i7 3632QM, 16GB 1600MHz DDR3, RME BabyFace, Samsung EVO SSD x2, forte 4, Kawai ES100, Kurzweil PC2, VB3, Alchemy, Kontakt 5, Omnisphere 2, Diva, ZebraHZ, Bazille, Pianoteq 5 Standard, Falcon, various effects

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Mon Oct 20, 2014 3:36 pm

Each scene is a song. I have 12 sampled guitars and the scene is one or more guitars loaded to suit the style of song. I'm using it for live performance as I sing. The song "Four strong winds" for example uses a nylon finger picked guitar, whilst "Folsom prison blues" uses a left panned Strat, a right panned Les Paul with a 12 string acoustic in the middle all strummed. As I call up each song on my iPad, a program change is sent to Forte to bring up the required scene.

Meistermacher
Posts: 22
Joined: Tue Jan 12, 2010 4:48 am
Location: Germany

Re: Midi scene change after 127

Postby Meistermacher » Tue Oct 21, 2014 1:08 pm

Hi bigalminal
from Forte 2 Manual - unfortunately this part is missing in Forte 3 Manual:
"Accessing Large Numbers of Scenes using Bank Select
By default, a bank of scenes consists of up to 128 scenes, each selectable
via program change. If more than 128 scenes exist in the active setlist,
MIDI bank select (CC0 and CC32) can be used to select alternate banks
of 128 scenes. In order for this feature to work, the controller must send
bank selects starting at 0, 1, 2, etc. Some devices use different bank
numbering schemes that may not work.
NOTE: Using alternate MIDI controllers:You may change the
number of scenes per bank by modifying a setting in OPTIONS.
INI. Select Tools|View INI Files… and open OPTIONS.INI. Find
the line that says “ScenesPerBank=128” and change that to a
different value. If you change this to 4, for example, you must
select bank 1, program 0 to access the 4th scene in the setlist.
Likewise, bank 2, program 2 would select the 10th scene. The
ability to alter the number of scenes per bank can be useful when
using some MIDI controllers like guitar footboards that select
programs using separate pedals."

Gert

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Thu Oct 23, 2014 4:28 pm

Hey Gert,
Thanks so much for your help. This is the best response I've had to any of my posts on this forum. And the most helpful:). I'll try it out over the weekend.

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Wed Oct 29, 2014 3:37 am

Gert,
I've been trying without much success. I can select the bank on the device that sends and it will select the 129th scene, but then I cant change back to previous scenes. Why would this be? Are there any setting changes I need to make in Forte for scene 129?

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Wed Oct 29, 2014 4:20 am

I just got it sorted. Nothing to do in Forte. I just set the bank to 1 in the sender and went back to program zero to start the whole process all over again. Then I had to go back and set the bank to zero for the previous 128 scenes. Working well now.

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Sat Nov 08, 2014 11:28 pm

Well, I was wrong. Its not working at all. I have added scene 128 which should be Bank 1 prog 0. but Forte keeps jumping to scene 4 on bank 1. And if I add scene 5, Forte will jump to that even though the program change was left at 4. Forte always jumps to the last song in the list no matter how many there are or what program number is set.

Mike - can you help please?
1 How do I get Forte to change to the correct scene?
2 Why does it always jump to the last one in the list?
3 Is this a bug?

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Mon Nov 10, 2014 12:33 pm

I'm not sure why answers are hard to get on this forum. Can someone please tell me how to set up Forte to receive a bank change then a program change within the new bank.

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Midi scene change after 127

Postby MikeG » Mon Nov 10, 2014 9:20 pm

Sorry replies are so delayed - there's simply so much to do. Working on Forte 4 and a new web site.

I'll set up a rack file with > 128 scenes in it and check it out.

Mike
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Midi scene change after 127

Postby MikeG » Mon Nov 10, 2014 10:59 pm

Confirmed Forte is working correctly. You just have to make sure your MIDI controller is transmitting the right CC values for bank select. I suggest you load MIDI OX and look at the MIDI input coming from your controller.

I created a rack with 200 scenes in it and when CC 32/0 = 0/0, I PC change from 1-128, and when LSB goes to 1 then the PCs change from 129-200
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

Lucien
Posts: 48
Joined: Wed Aug 16, 2006 1:53 pm
Location: France

Re: Midi scene change after 127

Postby Lucien » Tue Nov 11, 2014 4:23 am

Confirmed here.
I use 2 banks of 128 scènes since a long time.
I recall it with my old master keyboard Yamaha KX76(send lsb Mike as just explained)
Lucien

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Tue Nov 11, 2014 11:54 am

Thanks for the replies. Yes I also now have Forte changing scenes correctly. There is nothing to set in Forte. My mistake has been setting the sending controller bank msb and bank lsb to both send when it should have been just bank lsb.

MikeG
Posts: 3936
Joined: Tue Nov 19, 2002 11:56 am
Location: Houston, TX, USA
Contact:

Re: Midi scene change after 127

Postby MikeG » Mon Nov 17, 2014 9:58 pm

Awesome - glad you figured out the issue.
----------------
Mike (brainspawn)
www.brainspawn.com/support

PLEASE NOTE that the forum is not monitored as frequently as the support site above. This forum is intended primarily as a way for users to ask other users questions about the use of Forte.

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Sun Nov 23, 2014 8:29 pm

Thanks Mike. It was quite a relief getting it working correctly. Now can you help me out on my latest post "Setting Forte to receive on one channel only"

sosKeys
Posts: 146
Joined: Wed Apr 05, 2006 8:07 pm
Location: San Diego, CA USA
Contact:

Re: Midi scene change after 127

Postby sosKeys » Mon Nov 24, 2014 1:22 am

In the Forte 3 menu, go to View/Setlist Manager/Scenes and Setlists/Basic Scene Automation, enable Change scene with MIDI Program Change. There are dropdown boxes to select a (MIDI) port and channel once the selection is enabled.

-andy

bigalminal
Posts: 92
Joined: Sat Feb 01, 2014 8:42 pm

Re: Midi scene change after 127

Postby bigalminal » Mon Nov 24, 2014 2:24 am

OH thanks so much.


Return to “Forte and EHCo”

Who is online

Users browsing this forum: No registered users and 1 guest