NI Kontakt: Exception when updating scene / saving rack

Post here if you encounter problems using a plugin in forte

Moderator: MikeG

JohannesD

NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Mon Jul 25, 2011 2:15 pm

Hi,
I have an annoying problem with Forte and Kontakt: Sometimes when I update a scene or when I save the whole rack, I get the following error:

NI Vintage Organ created an exception when being asked for save data size.

I also get this for other libraries in Kontakt, but only for one at a time.

I also had a similar issue recently when trying to reorder the scenes in the scene editor. First of all, I have to say that the whole Forte GUI is quite slow for me, I dont know why. While the audio performance is very stable, Forte tends to freeze when e.g. opening a vst's console. At this moment, I am running a Stress test and the GUI is not reacting at all. Is this normal? However, when I open the scene editor in order to reorder the scenes and click the "move up" button, I have to reset the computer as I even cannot start the process manager (Ctr+ Alt + Del). After a fresh reboot and immediately going to the scene manager and trying it again, Forte quits. I looked at the Log file and found the message above, however for all kontakt libraries. What can I do?

My system: Intel Core 2 Duo, Windows XP, SSD (only the samples), Ehco, Forte Version 2.2 (build 14.2101)

Thanks in advance!
Johannes

Dirk Offringa
Posts: 3508
Joined: Sat Mar 06, 2004 3:44 am
Location: Sainte Anastasie, France
Contact:

Re: NI Kontakt: Exception when updating scene / saving rack

Postby Dirk Offringa » Tue Jul 26, 2011 3:28 am

That is abnormal.... there are no known issues with the forte gui or the plugin consoles. Maybe there's something wrong with your OS or graphic card, or some other app stealing ressources, some confict somewhere, a driver...... I'm afraid you must troubleshoot your whole system! PS the latest build of forte is 2.25

Dirk
Life would be much easier if I had the source code.

JohannesD

Re: NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Tue Jul 26, 2011 4:17 pm

Hi,
Thanks for your reply! Are there ways to find out what forte is waiting for when it freezes?

I will update forte, thanks for the hint about the latest release.

Bye,
Johannes

JohannesD

Re: NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Wed Jul 27, 2011 3:16 pm

Hi,
I found out that showing the console is only slow for Kontakt. Consoles of other Plugins show up immediately. What can I do? I already updated to the latest version of Forte, Kontakt is also up to date.

Bye,
Johannes

JohannesD

Re: NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Sat Jul 30, 2011 6:25 pm

I did a complete reinstall of windows XP, Forte and Kontakt. Results:
a) The console of Kontakt still shows up with a delay of some seconds
b) By quickly moving a scene upwards in the scene manager (sevelral clicks on "Move Up"), Forte crashed with the following messge:

A crash has occured with a Plugin.
Path: [...] Kontakt 4 16out.dll
Name: Kontakt 4
[...]

Please contact the Plugin vendor for support.
Version: 2, 2, 25, 2112
Details: m_pAEffect->dispatcher(m_pAEffect, effSetChunk, TRUE, sizeProgram, pChunkSet->chunk, 0.0f)

NOTE: This is intended to....

[...]

Is there no one with the same problem?

Bye,
Johannes

Dirk Offringa
Posts: 3508
Joined: Sat Mar 06, 2004 3:44 am
Location: Sainte Anastasie, France
Contact:

Re: NI Kontakt: Exception when updating scene / saving rack

Postby Dirk Offringa » Sun Jul 31, 2011 3:35 am

Life would be much easier if I had the source code.

JohannesD

Re: NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Sun Jul 31, 2011 4:16 am

Hi,
I have 3 dlls in the vst folder related to Kontakt:

Kontakt 4.dll
Kontakt 4 8out.dll
Kontakt 4 16out.dll

However, in forte I just clicked on Add -> Native Instruments GmbH -> Kontakt 4 which is the only Item in the Menu. I dont know why Forte picked the 16out dll and does not show the others. However, when I click "Search", I can choose between all three.

My problem now is that my Rack which has several scenes uses the 16 out version. Is there a simple way to replace them with the single out version? I already tried to rename the dlls but Forte shows an error message ("This FXP file cannot be loaded because it does not appear to contain data for this VST plugin"). What can I do?

By the way, I installed Win 7 now and have the same problem.

Thanks in advance for any tips.
Bye,
Johannes

Dirk Offringa
Posts: 3508
Joined: Sat Mar 06, 2004 3:44 am
Location: Sainte Anastasie, France
Contact:

Re: NI Kontakt: Exception when updating scene / saving rack

Postby Dirk Offringa » Sun Jul 31, 2011 7:46 am

Hi Johannes,

I am afraid I am not at all a Kontakt user, there are some other guys around here who are, mayby someone could take over? I'm on tour, and reaaly can't help much more here.

As far as replacing a plugin is concerned, this can be done using the copy function of forte, it's designed to do just this. Check all the options and you should be OK, provided the Kontakt dll data are compatible between Kontakt version. Make a backup of your rack of course!

Dirk
Life would be much easier if I had the source code.

JohannesD

Re: NI Kontakt: Exception when updating scene / saving rack

Postby JohannesD » Sun Jul 31, 2011 12:20 pm

Hi Dirk,
thank you so much for your replies. I found a crashlog which has been created by Kontakt at the last crash of forte. It is encrypted, so I cannot get anything out of it, but I sent it to NI.

However, I made up my mind today to end this... Half a year ago, I switched to software instruments in order to get better sound for a low price. But now I realize, that there is one more important thing which I cannot get from software instruments: trust in my gear. The upcoming gigs, I will play with my motif-rack es and a cx-3 organ (most probably with an external leslie sim which I can hopefully afford by reselling Komplete 7). Sound is also great, if not even better when being used in a band, and they work without problems. After working the whole day as a programmer and software architect, I dont want to get crazy sitting again in front of a screen instead of making music.

I still like Forte, it is probably the best you can get for vst instruments. Maybe I will use it just for controlling my hardware instruments via midi.

Bye,
Johannes

Dirk Offringa
Posts: 3508
Joined: Sat Mar 06, 2004 3:44 am
Location: Sainte Anastasie, France
Contact:

Re: NI Kontakt: Exception when updating scene / saving rack

Postby Dirk Offringa » Tue Aug 02, 2011 5:51 am

Well yes, if you find this more comfortalble, no problem! This being said, if you found a Kontakt-generated crashlog, than Kontakt crashed. You did the right think by sending the report to NI, because here we can't do much more about it.

greets
Dirk
Life would be much easier if I had the source code.

fab
Posts: 515
Joined: Sat Sep 03, 2005 9:53 am

Re: NI Kontakt: Exception when updating scene / saving rack

Postby fab » Wed Aug 03, 2011 5:54 am

well i am not sure why you want to use a certain kontakt version ? - i have just been adding "kontakt" for years (whatever version) and it works. forte 2 can't use any more than one stereo output, so it really doesn't matter much.

concerning trust: it all boils down to complexity. a simple software based setup can be trustier than a complicated workstation/midi rack configuration and vice versa. there is nothing as simple and intiutive as a nord stage, for sure, but you pay a lot of money for a sound and keyboard feel that's OK but not great.

gyohng

Re: NI Kontakt: Exception when updating scene / saving rack

Postby gyohng » Tue Aug 16, 2011 8:02 am

We have the same problems with TruePianos between versions 1.9.0 and 1.9.2, the latter one fails to load old presets (reported by a customer). The message comes from Forte or some wrappers on the system, and certainly not from the plugin.

Technical information (for developers):

The problem is in FXP fxVersion field, which is taken from cEffect.version (of VST specification). Brainspawn treats a different value in this field as a reason for making the preset incompatible, while I think this should not be the case (only fx ID should be validated).

For example, the version can be 0x10400, which would mean 1.4.0, and 0x10401, which might be a minor update to the plugin - and this would make the preset incompatible. I tried to find the information from Steinberg on treating this subject, but there is no information available. JUCE library, as it seems so, just like many other hosts just ignores this flag.

Developers: please ignore this field, or at least add an option to disable this check. This is not a 'format version' but a 'plugin version' field, which - to make things compatible - forces plugin developers essentially to keep it assigned to the very first version in order to keep presets compatible

Thanks,
George.

(there is another mentioning on the forum here: http://www.brainspawn.com/forum/viewtop ... f=2&t=3487 - I will repost the message there as well)


Return to “Plugin Issues”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest